MySQL organizes all the data as tables, irrespective of storage
engine used. If you are using MySQL with InnoDB tables, these
tables might get corrupt due to hardware faults, unexpected power
failure, MySQL code errors, kernel bugs and other similar
reasons. In such cases, InnoDB will typically give some errors
indicating table corruption. As a data restoration source, you
will need to use your latest database backup. But in case if
backup fails to restore required information or doesn’t exist,
you should scan your damaged database using third-party MySQL
Repair or MySQL Recovery tools.
You might encounter the similar error message while accessing an
InnoDB table:
“#1033 - Incorrect information in file: '"table name" .frm”
MySQL crashes after you receive this error message.
Cause: You receive this error message if …
The latest from the MySQL community
Ideas, releases, practical guides, and perspectives from the people building with MySQL.
MySQL Backup: Table By Table Backup With Auto Rotation, For Easy Restoration Of Partial/Full Database
Here is a MySQL backup script which can take table by table backups (individual backup files of each table of each database) in a compressed format. It also provides an automatic rotation of old backup files. The backup script handles innodb and myisam tables separately.
LVM (Logical Volume Management) is a very important tool to have in the toolkit of a MySQL DBA. It allows you to create and extend logical volumes on the fly. This allows me to, say, add another disk and extend a partition effortlessly. The other very important feature is the ability to take snapshots, that you can then use for backups. All in all its a must have tool. Hence, this guide will allow you to understand various terminologies associated with LVM, together with setting up LVM volumes and in a later part will also show you how to extend...
Listening to the OurSQL podcast: Repli-cans and Repli-can’ts got me thinking,
what are the issues with MySQL replication that Sarah
and Sheeri didn’t have the time to include in their
episode. Here’s my list:
Replication Capacity Index This is a concept introduced by
Percona in last year’s post: Estimating Replication Capacity which I
revisited briefly during my presentation at this year’s MySQL Users
Conference. Why is this important? Very …
Previously in the backup series:
Backup Series #1: Backup Glossary
Backup Series #2: Backup Tools You Already Have (mysqlhotcopy and
mysqldump)
Backup Series #3: Looking Through the Lenz (snapshots including
LVM)
Backup Series #4: Advanced Logical Export Features (advanced
mysqldump)
Backup Series #5: Xtrabackup
This week we talk with Chander Kant, CEO of Zmanda, about how Zmanda Recovery Manager makes backup and recovery of MySQL backups very easy, whether you are using storage level snapshots, hot backup tools or even logical backups. Full and incremental backups (and …
[Read more]With this revision, My xtrabackup branch has been merged into trunk.
What does this mean? It means that we now get a drizzlebackup.innobase binary which is the xtrabackup port for Drizzle. Exciting times.
A user on a linux user group mailing list asked about this, and I was one of the people replying. Re-posting here as I reckon it’s of wider interest.
> [...] tens of gigs of data in MySQL databases. > Some in memory tables, some MyISAM, a fair bit InnoDB. According to my > understanding, when one doesn’t have several hours to take a DB > offline and do dbbackup, there was/is ibbackup from InnoBase.. but now > that MySQL and InnoBase have both been ‘Oracle Enterprised’, said > product is now restricted to MySQL Enterprise customers.. > > Some quick searching has suggested Percona XtraBackup as a potential > FOSS alternative. > What backup techniques do people employ around these parts for backups > of large mixed MySQL data sets where downtime *must* be minimised? > > Has your backup plan ever been put to the test?
You should put it to the test regularly, not just when it’s needed. …
[Read more]Backups are an integral and very important part of any system. Backups allow you to recover your data and be up and running again, in the advent of problems such as system crashes, hardware failures or users deleting data by mistake. I had been evaluating backup solution for a while but to be honest I really wasn't satisfied with the solutions available until I came across XtraBackup and I am loving it since. In this post I intend on showing how to do backups and restores using XtraBackup.
Previous podcasts in the backup series:
Backup Series #1: Backup Glossary
Backup Series #2: Backup Tools You Already Have (mysqlhotcopy and
mysqldump)
Backup Series #3: Looking Through the Lenz (snapshots including
LVM)
Backup Series #4: Advanced Logical Export Features (advanced
mysqldump)
Special Guest Valentine Gostev, QA engineer at Percona, talks about Percona's Xtrabackup, an open source tool for consistent online physical backup of InnoDB and XtraDB.
…
[Read more]
Previous podcasts in the series:
Backup Series #1: Backup Glossary
Backup Series #2: Backup Tools You Already Have (mysqlhotcopy and
mysqldump)
Backup Series #3: Looking Through the Lenz (snapshots including LVM)
ERRATA:
Giuseppe Maxia points out via twitter "The mysqldump option to
skip table creation is not '--no-create-table' but
'--no-create-info' " -- he's right!
Feedback/News:
We had some great feedback on the snapshots podcast, and we
explain how to get some swag from us.