Community journal

The latest from the MySQL community

Ideas, releases, practical guides, and perspectives from the people building with MySQL.

Follow the feed
Showing entries 181 to 190 of 307 « Previous | Next »
Displaying posts with tag: Percona XtraDB Cluster (reset)
Running Percona XtraDB Cluster in a multi-host Docker network

In this post, I’ll discuss how to run Percona XtraDB Cluster in a multi-host Docker network.

With our release of Percona XtraDB Cluster 5.7 beta, we’ve also decided to provide Docker images for both Percona XtraDB Cluster 5.6 and Percona XtraDB Cluster 5.7.

Starting one node is very easy, and not that different from starting Percona Server image. The only an extra requirement is …

[Read more]
Percona XtraDB Cluster 5.7 beta is now available

Percona is glad to announce the release of Percona XtraDB Cluster 5.7.11-4beta-25.14.2 on June 9, 2016. Binaries are available from the downloads area or our software repositories.

NOTE: This beta release is only available from the testing repository. It is not meant for upgrade from Percona XtraDB Cluster 5.6 and earlier versions. Only a fresh installation is supported.

Percona XtraDB Cluster 5.7.11-4beta-25.14.2 is based on the following:

  • …
[Read more]
Galera Error Failed to Report Last Committed (Interrupted System Call)

In this blog, we’ll discuss the ramifications of the Galera Error Failed to Report Last Committed (Interrupted System Call).

I have recently seen this error with Percona XtraDB Cluster (or Galera):

[Warning] WSREP: Failed to report last committed 549684236, -4 (Interrupted system call)

It was posted in launchpad as a bug in 2013: https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1434646

My colleague Przemek replied, and explained it as:

Reporting the last committed transaction is just a part of the certification index purge process. In case it fails for some reason (it occasionally does), the cert index purge may be a little delayed. But it does not mean the transaction was not applied successfully. This is a warning after all.

If we look up this error in the source code, we realize …

[Read more]
Percona XtraDB Cluster 5.6.29-25.15 is now available


Percona
is glad to announce the new release of Percona XtraDB Cluster 5.6 on May 20, 2016. Binaries are available from the downloads area or our software repositories.

Percona XtraDB Cluster 5.6.29-25.15 is now the current release, based on the following:

[Read more]
Understanding GCache and Record-Set Cache in Percona XtraDB Cluster

In this blog, we will examine the differences between GCache and Record-Set Cache in Percona XtraDB Cluster.

In Percona XtraDB Cluster (PXC), there is the concept of GCache and Record-Set cache (which can also be called transaction write-set cache). The use of these two caches is often confusing if you are running long transactions, as both of them result in the creation of disk-level files. Let’s understand what their main differences are.

Record-Set Cache

  • When you run a long-running transaction on any particular node, it will try to append a key for each row that it tries to modify (the key is a unique identifier for the row {db,table,pk.columns}). This information is cached in out-write-set, which is then sent to the group for …
[Read more]
Understanding Percona XtraDB Cluster threading model

In this blog, we’ll discuss how the Percona XtraDB Cluster threading model works.

Percona XtraDB Cluster (PXC) creates a different set of threads to service its operations. These threads are in addition to existing MySQL threads. Let’s understand what these threads are and how they’re used. There are three main groups of threads:

  1. Applier thread(s)
    1. Applier threads are meant to apply write-sets that the node receives from other nodes (through cluster). (write-message is directed through
      gcv_recv_thread
      .)
    2. The number of applier threads is controlled using the
      wsrep_slave_thread
       configuration. (The default value is 1, so at least one wsrep applier thread …
[Read more]
Percona XtraDB Cluster 5.6.28-25.14 is now available

Percona is glad to announce the new release of Percona XtraDB Cluster 5.6 on January 29, 2016. Binaries are available from the downloads area or from our software repositories.

Percona XtraDB Cluster 5.6.28-25.14 is now the current release, based on the following:

[Read more]
Percona XtraDB Cluster 5.6.27-25.13 is now available

Percona is glad to announce the new release of Percona XtraDB Cluster 5.6 on January 11, 2016. Binaries are available from the downloads area or from our software repositories.

Percona XtraDB Cluster 5.6.27-25.13 is now the current release, based on the following:

[Read more]
Better high availability: MySQL and Percona XtraDB Cluster with good application design

High Availability

Have you ever wondered if your application should be able to work in read-only mode? How important is that question?

MySQL seems to be the most popular database solution for web-based products. Most typical Internet application workloads consist of many reads, with usually few writes. There are exceptions of course – MMO games for instance – but often the number of reads is much bigger then writes. So when your database infrastructure looses its ability to accept writes, either because traditional MySQL replication topology lost its master or Galera cluster lost its quorum, why would you want to the application to declare total …

[Read more]
Fixing inconsistency on MySQL Slave of Galera Cluster

This blog post explores the syncing options for an inconsistent MySQL slave of Galera cluster node using pt-table-sync

The post Fixing inconsistency on MySQL Slave of Galera Cluster first appeared on Change Is Inevitable.