Community journal

The latest from the MySQL community

Ideas, releases, practical guides, and perspectives from the people building with MySQL.

Follow the feed
Showing entries 36431 to 36440 of 45465 « Previous | Next »
Replication Presentation at the November 2007 Boston MySQL User Group

Patrick Galbraith, former MySQL employee who helped write replication, came to the November 2007 Boston MySQL User Group and did a fantastic presentation on replication, including showing how to set up replication and walking us through the steps in real-time, setting up an example server.

Smaller, 320x240, 293M WMV file for download

References mentioned in the video:
Brian Aker's DBIx::Password

Giuseppe Maxia's article about federated tables -- I think that's the right one, feel free to comment if it's not.

read more

Solaris, IPV6, getnameinfo() completely busted?

Dear LazyWeb,

No matter how I modify this following code it does not work with Solaris. Solaris always returns "non-recoverable name resolution failure":

     int error;
     char port_buf[NI_MAXSERV];
     size_socket addrLen = sizeof(vio->remote);
     if (getpeername(vio->sd, (struct sockaddr *) (&vio->remote),
                     &addrLen) != 0)
     {
       DBUG_PRINT("exit", ("getpeername gave error: %d", socket_errno));
       DBUG_RETURN(1);
     }

     if ((error= getnameinfo((struct sockaddr *)(&vio->remote),
                             sizeof(struct sockaddr_storage),
                             buf, buflen,
                             port_buf, NI_MAXSERV, NI_NUMERICHOST|NI_NUMERICSERV)))
     {
       WATCHPOINT_STRING(gai_strerror(error));
       DBUG_PRINT("exit", ("getnameinfo gave error: %s",
                           gai_strerror(error)));
       DBUG_RETURN(1);
     }


…

[Read more]
Recent MySQL builds in CentOSPlus

Peter notes that you indeed can find pretty recent Enterprise level MySQL rebuilds over at the CentOSPlus repository.

Good things come to those who wait :)

Log Buffer #78: a Carnival of the Vanities for DBAs

This week, Daniel Krook brings us the 78th edition of Log Buffer, the weekly review of database blogs. Up next week is Hasan Tonguç Yilmaz for his second LB. You too can do one — send a note to me, the Log Buffer coordinator to get started. It’s fun! Here is Daniel Krook’s Log [...]

Zimbra ZCS 5.0 GA - is it really a GA release?

I took the opportunity today evening to get myself upgraded (from 4.5.3_GA_733) to the latest (5.0.0_GA_1869) open source version of Zimbra - ZCS 5.0 GA. The database migration took about the longest, mainly due to some schema changes. Lots of starts and stops to the database. Its now running MySQL 5.0.45 Community.

What prompted the upgrade? A few days ago, I got a bunch of new packages, and rebooted the server (new kernel). To my dismay, Zimbra started to have issues - amavisd wouldn’t start. This meant that there was a large amount of mail, sitting in the queue, not being delivered. Things you don’t normally check for, immediately, anyway.

Turns out Compress::Zlib was too old. Well, not the system provided Compress::Zlib, but the Zimbra provided Compress::Zlib. Kind of annoying when there …

[Read more]
Open source's non-problem with interoperability

It's really funny, though a bit pathetic, to see the media pick up a theme and run with it. In this case, it's the idea that open source has problems with interoperability, and that it's somehow crimping open-source adoption. This is ironic because proprietary enterprise software has had this problem for decades...and still does. In fact, it is the fault of proprietary software that we have an interoperability problem at all.

Open source, thriving on open standards, is a huge step in the right direction.

It's also ironic because if you talk with MySQL, Alfresco, SugarCRM, Loopfuse, MuleSource, etc. you'll find that not a single one of us is seeing this interoperability problem crimping adoption. Want to …

[Read more]
CentOS Comes with free build of MySQL Enterprise ?

As I already wrote you can well go to Linux distribution vendors if you're looking for recent MySQL version in a hassle free binary form. (On the time of this writing you could only get binaries for MySQL Community 5.0.45 from MySQL Download Pages which was released in July and so about half a year old.

If you prefer to run binaries based on Enterprise codebase - the most up to date version 5.0.54 is now available for CentOS starting with CentOS4:

mysql.x86_64 5.0.54-1.el4.centos centosplus
mysql-bench.x86_64 5.0.54-1.el4.centos centosplus
mysql-devel.x86_64 5.0.54-1.el4.centos …

[Read more]
Announcing Scalecast - A Meta Podcast about Designing Scalable Systems

A

My Book Has Been Printed

Well, it's taken over a year but it has finally arrived. I started writing the book back in Aug 2006. I finished in late Jan 2007 and the technical editor finished his work in March. Now, In Jan 2008, EnterpriseDB: The Definitive Reference is available. I'm glad I didn't wait for the movie. ;-)

It's kind of ironic. Just this morning, I posted that I am working on my second book. My wife called me at work and told me two boxes of books had arrived. 2008 is turning out to be a good year. I wonder if I should start planning my MySQL book?

Anyway, the book looks good. I've already found a few typos and grammar errors just skimming around. I like the font and the pages look really crisp. All in all, I have to say I am very happy that the book is out.

Check out …

[Read more]
Why Participating in a Community is Important and Beneficial

Back in 2000 I began writing for swynk.com in hopes of learning more about SQL Server and beginning to make a name for myself in the SQL Server community. That was a little over seven years ago. As SQLServerCentral.com came online, I transitioned to it, writing articles and contributing heavily in the forums. Opportunities abounded from this effort, with the chance to write an eBook, the chance to become a regular columnist for SQL Server Standard Magazine, and later a chance to become a co-author of an in-print book, …

[Read more]