Community journal

The latest from the MySQL community

Ideas, releases, practical guides, and perspectives from the people building with MySQL.

Follow the feed
Showing entries 1031 to 1040 of 3187 « Previous | Next »
MySQLでユーザーを作ったときのハッシュ値から同じ`PASSWORD`でユーザーを生成する

MySQL5.7の話。本日隣の人から教えてもらった事。

ユーザーを作るとき等でAPサーバーのIPが追加や変更されるときにハッシュ値から同じパスワードを設定することができる。

例えば、

fuki [(none)]> create user 'fuki'@'127.0.0.1' identified by 'Abc123';
Query OK, 0 rows affected (0.07 sec)

fuki [(none)]> SELECT user,host,authentication_string FROM mysql.user WHERE user='fuki' ORDER BY 1,2;
+------+-----------+-------------------------------------------+
| user | host      | authentication_string                     |
+------+-----------+-------------------------------------------+
| fuki | 127.0.0.1  | *7A8BBCB18A250055A6BB98ECFA33A8174D219504 |
+------+-----------+-------------------------------------------+
1 rows in set (0.00 sec)

…

[さらに読む]
GTIDを有効にしているのにレプリケーションのポジションがズレる場合

TL;DR

GTIDを有効にしてレプリケーションを組んでいる( MASTER_AUTO_POSITION=1 …

[さらに読む]
MySQL 8.0.2以降ではundoテーブルスペースファイルを勝手に拡張してくれるみたい

MySQL 5.7で InnoDB UNDO Log Truncation が追加されたものの、 innodb_undo_tablespaces は mysqld --initialize の時に既に指定されていないといけなくて、一度ibdata1が初期化されてしまうと二度と変更できないという制約がありました。 こんなログが出て起動に失敗したりとか失敗したりとか失敗したりとか

2017-07-19T16:00:43.739980+09:00 0 [ERROR] InnoDB: Expected to open 2 undo tablespaces but was able to find only 0 undo tablespaces. Set the innodb_undo_tablespaces parameter to the correct value and retry. Suggested value is 0

ところで、 MySQL …

[さらに読む]
吉祥寺.pm 11でMySQLのステータスモニタリングについて話をしてきた

吉祥寺.pm11 - connpass 「夏の吉祥寺、夏のpm」ってことで行ってきました。 思い起こせば一昨年の YAPC::Asia Tokyo 2015 2日目のLT 、俺のLTの次が magnoliak さんで、「おー吉祥寺かー、いいなーもう少し西側に住んでれば行きたいなー」とかそんなことを考えていました。
(このことをおぼえていて下さったそうで、懇親会でそんな話をできたりしました! ビバYAPC) それから2年、多摩地域の住人となった今こそ、吉祥寺.pmに参加するのだ!!

…

[さらに読む]
割と安全にpt-online-schema-changeとかpt-table-checksumを取るための簡単なやり方

TL;DR

[さらに読む]
mysqld_safeに "--ledir option can only be used as command line option" と言われたら

TL;DR

  • my.cnfに書いてある ledir の行を消す
  • 今までmy.cnfに書いてあった ledir は mysqld_safe にコマンドラインオプションとして渡す
    • ex. mysqld_safe --defaults-file=/data/mysql/my.cnf --ledir=/usr/local/mysql/bin

パッケージもの以外のMySQLで、 mysqld_safe を起動した時に↓のように言われることがある。

mysqld_safe --ledir option can only be used as command line option, found in config file

読んでそのまま、 ledir はコマンドラインオプション( mysqld_safe --ledir=.. の形式)で渡さなければいけないのに、コンフィグファイルから ledir の項目が見つかった、という意味。 MySQL 5.5.55とそれ以降、MySQL …

[さらに読む]
MySQLの高可用性構成の展望2017年版

このブログでは、さまざまなMySQL高可用性オプションについて考察します。

ダイナミックなMySQLエコシステムは、MySQLを中心に構築された多くの技術を急速に進化させています。これは、MySQLの高可用性(HA)の側面に関連する技術に特に当てはまるでしょう。 私が2009年にPerconaに入社したとき、こういったHAの技術のいくつかは非常に人気がありましたが、それ以来ほとんどは忘れられています。その同じ期間で、新しい技術が登場しました。読者にいくつかの視点を提供しながら、出来ればより良い選択をする助け�になるように、2017年のMySQL HAの展望をレビューしようと思います。このレビューは3つのパートに分かれています。最初のパート(この記事)は、長年に渡って存在していた技術、すなわちthe …

[さらに読む]
MySQLのauto_incrementは実質ULLONG_MAX - 2で打ち止まるはなし

TL;DR

とある事情があってInnoDBのAUTO_INCREMENT関連のコードを読んでいた時に、innobase_next_autoincの中でこんなコードになっていることに気が付いた。

 2497         if (block >= max_value
2498 || offset > max_value
2499 || current >= max_value
2500 …
[さらに読む]
MySQL 8.0ではデフォルトで濁点半濁点を区別しなくなる

4月にMySQL 8.0のUnicodeと日本語対応についてManyi Luさんとディスカッションする会があって、かなりいろいろ話してとてもよい会だった。その後いろいろ考えて感じてる懸念を端的に書き記しておく。

デフォルトのcollationがutf8mb4_0900_ai_ciになった

これに関して僕は強い懸念を持っている。MySQL …

[さらに読む]
MySQL 5.6のmysqldumpでMySQL 5.7のサーバーに接続してダンプを取ろうとするとコア吐く件

TL;DR

  • MySQL 5.7.12とそれ以降のmysqldumpなら大丈夫
  • 実はバージョン依存ではなく sql_mode=ONLY_FULL_GROUP_BY 依存

別のものを調べている時に /var/log/messages を見てたら、なんかがコア吐いてるのに気が付いた。

Jun 20 04:26:42 archive_host kernel: mysqldump[28611]: segfault at 0 ip 00000030b152859a sp 00007fffd760a358 error 4 in libc-2.12.so[30b1400000+18b000]
Jun 20 04:26:42 archive_host abrtd: Directory 'ccpp-2017-06-20-04:26:42-28611' creation detected
Jun 20 04:26:42 archive_host abrt[28613]: Saved core dump of pid 28611 (/data01/mysqlbin/mysql-5.6.20-linux-glibc2.5-x86_64/bin/mysqldump) to /var/spool/abrt/ccpp-2017-06-20-04:26:42-28611 (2609152 …
[さらに読む]