Installing Maatkit when you have Perl-DBD-MySQL issues

Note to self:

If I have a problem installing Maatkit scripts because maybe Percona server created conflicts with dependencies, here is what I did to solve that:


  1. wget http://maatkit.googlecode.com/files/maatkit-7540-1.noarch.rpm
  2. yum localinstall --nogpgcheck maatkit-7540-1.noarch.rpm --skip-broken


On point 2, make sure what you install before you say "yes".